Reports show "No data for your filter selection"

  • 28 April 2022
  • 3 replies

Hi Copper Community, 

I’ve recently started using Copper and building reports based on report templates. However, activity related reports (e.g. Activity by User, Activity Touchpoints by Company /Person & Opportunity) do not seem to work. They always show “No data for your filter selection” although I’ve plenty of activities on companies and persons. I’ve tried adjusting data range to “all time” but it does not help. 

 Can anyone help? Thanks!

3 replies

Userlevel 6
Badge +5

Hi @pauline, thanks for posting!

Looking at your screenshot, I wonder if it has to do with your filter settings. You have filters for “Activity Company” and “Activity Opp” at the top. Can click into those? I’m wondering if you’ve accidentally selected a Company or Opp that doesn’t have any activities. 🤔

It may be easier just to remove those filters entirely. You can do this by clicking the Edit button and then dragging those filter boxes off to the left side.

Also, I want to mention that only Activities that count as Interactions will be pulled into the reporting system. You can check which ones these are by going to Settings > Customize > Activity Types. You’ll see a column of checkmarks that indicate whether an Activity Type is an Interaction (this means it counts towards the Interaction count for a Person/Company/Opp).

Anyways, let me know about that filter thing :) 

Hi @Michelle from Copper :) Thanks for your reply! I’ve removed those filters entirely. Still the same problem though. I’ve selected emails, phone calls, and meetings as interactions, so they should show up… Do you have any other idea how to solve this? Thank you!

Userlevel 6
Badge +5

@pauline hm that’s strange, it could be a bug or maybe I’m just missing something. I’m grabbing a second opinion from our team. Hang tight!