Question

ACTIVITY LOG malfunction

  • 4 August 2023
  • 6 replies
  • 17 views

When I send an email to my contact, this email will automatically show up in my contact page, as an ACTIVITY, without the needs to LOG an activity by hand.

When I send the same email within my Gmail, instead using Copper CRM, it behave in the same way.

However, when I want to send the same email, within my Gmail, using the Gmail function SCHEDULE SEND which appears on the bottom, clicking the little arrow, beside the SEND word, the email is correctly sent at the scheduled time, but it will not show up as an activity into my contact’s page within Copper CRM.

How to fix this problem?


6 replies

Userlevel 7
Badge +7

Hi @DanHK, thanks for posting! I really appreciate your thorough explanation. Let me check with the team about this and we’ll get back to you shortly.

I may need to submit a technical ticket on your behalf. If that’s the case, you will receive an email from our system. I’ll also give you a heads-up in this thread. Thanks Dan!

Userlevel 7
Badge +7

Hi @DanHK! I looked into this, and emails scheduled to send in Gmail are logged when you hit the Send button. And the timestamp reflects the scheduled send time. So based on that, you should see an email activity logged for your contact.

Can you confirm if that email has been logged since you first posted? If not, I may have to connect you to our technical team to take a closer look. Let me know. Thanks Dan!

Hi Michelle, thanks for the test.
I may need to add a detail.
In RED color the details added.
 

From my previous post:


When I send an email to my contact, this email will automatically show up in my contact page, as an ACTIVITY, without the needs to LOG an activity by hand.

When I send the same email within my Gmail (using my primary email address), instead using Copper CRM, it behave in the same way.

When I send the same email within my Gmail (using my an alias email), instead using Copper CRM, it behave in the same way and the communication is logged into Copper CRM.

However, when I want to send the same email, within my Gmail, from my alias email, using the Gmail function SCHEDULE SEND which appears on the bottom, clicking the little arrow, beside the SEND word, the email is correctly sent at the scheduled time, but it will not show up as an activity into my contact’s page within Copper CRM.

If I send the email, from my primary email address, using the schedule function, then yes, the email is logged into Copper CRM

 

Userlevel 7
Badge +7

@DanHK gotcha, thanks for the additional detail. So we’re looking at emails sent from Gmail using the Schedule Send feature through an email alias. I’ll need to check with the team how that functions--I’ll get back to you.

Hi Michelle,

 

Have you got any feedback on the issue above?


Thanks
BR

Userlevel 7
Badge +7

Hi @DanHK, I spoke to one of our engineers about this, and it is what we call “expected behaviour.” If you’re interested in why, it’s due to the way Gmail handles scheduled sends through aliases. When you send a normal email through an alias, it updates your primary inbox. And that primary inbox is how Copper does email syncing. But Gmail does not seem to update the primary inbox when you do a scheduled send through an alias, so the Copper email sync doesn’t receive a signal about that email.

You could try adding our BCC email to the scheduled emails you send through an alias. This is an email address you but into the BCC so that it can get logged by Copper. You can find this in Settings > Personal Preferences > Email Settings & Templates > Copper Mailbox.

 

Another option is to manually relate those emails using the Chrome extension. I haven’t specifically tested this with an alias, but it’s worth a try.

 

Let me know if that helps!

Reply