Solved

Making a report dashboard public

  • 7 June 2022
  • 3 replies
  • 14 views

Hi,

 

When reports first came out it, new dashboards I created were public within our org. Now they default to private and I can’t figure out how to change. Can someone help me?

 

Thanks,

Hayley

 

icon

Best answer by Michelle from Copper 7 June 2022, 15:27

View original

3 replies

Userlevel 6
Badge +5

Hi @hayley.croteau! Great question. You are correct that Reports/Dashboards are private by default when you create them. You can adjust the sharing permissions using the Share button in the top right. Here are some screenshots:

The Share button is on the top right of your Dashboard.
Click the “+ Add” button
Select “All users.” Note, this actually means all users who are admins in Copper.
Click “Share.” Once you do, the Dashboard will say “Shared” instead of “Private”

Note that this shares with all other admins in your Copper system. So if you have someone who is a regular-level user, they still will not be able to access it.

 

Let me know if that’s helpful!

Ok thanks Michelle - I was able to fix my dashboards. That must be a new setting since the original dashboards I made when the new reports function came out were automatically public.

 

Also, it’s a bit odd that people have to be admin to see any reports. It just means I had to set everyone at admin level, which could come with other side effects. Could you suggest to the development team that perhaps you could invite non-admin users on a case by case basis to see reports? Thanks!

Userlevel 6
Badge +5

@hayley.croteau yes, the admin-per-admin privacy is a relatively new feature and defaults to Private. So that would explain why you saw them change to from available to all Admins to yourself only.

I’ll absolutely pass your feedback on the the Product team!

Also, I’m going to mark my first response as Best Answer so that other can find it easily. Thanks Hayley!

Reply